<

domingo, enero 07, 2007

El Gestor de Ajustes de Beryl aparecio totalmente renovado en la version svn del dia de hoy. (Y si queres actualizarlo, como hacerlo de manera facil)

En el dia de hoy se cambio radicalmente el formato del Gestor de Ajustes de Beryl (o Beryl Settings Manager) .

Ahora luce como podes ver en la imagen de tu derecha. Segun mi opinion es esteticamente hablando, muy superior a la version anterior, y en cuanto a los funcional, habra que acostumbrarse pero no parece mas complicado que las antiguas versiones. Ademas si mal no recordamos el mockup de este nuevo diseño fue un usuario de la comunidad en español de Beryl, el moderador del foro franzrogar.

Esta nueva version svn publicada durante el dia de hoy no es muy estable ahora asi que no es recomendable que la instales en tu estacion de trabajo productiva o cotidiana, salvo que te guste el hobby de solucionar problemas con programas en versiones no finales. En ese caso te va a dar muchas horas de entretenimiento y del bueno :) Si podes hacerlo en un segundo sistema operativo o en un live cd como el de Sabayon porque aunque tenga errores, funciona!.


Para instalar de manera rapida y sencilla esta version de Beryl, suponiendo que estas ya con el entorno de aceleracion grafica ya preparado (drivers, open gl y demas) y que sos usuario de Ubuntu Edgy Eft (6.10) seria a traves de los repositorios de Treviño (deberias seguir estos sencillos pasos) :

Editar los repositorios en tu sources.list

sudo gedit /etc/apt/sources.list

y agregar los repos de Treviño

a)
# Treviño's Beryl-SVN Ubuntu Repository
# GPG key: 81836EBF
deb http://download.tuxfamily.org/3v1deb edgy beryl-svn
deb-src http://download.tuxfamily.org/3v1deb edgy beryl-svn
b) Obtener la llave publica:
KEY=81836EBF; gpg --keyserver subkeys.pgp.net --recv $KEY && gpg --export --armor $KEY | sudo apt-key add -
Si ya tenes instalado Beryl

c) sudo apt-get update
sudo apt-get dist-upgrade

Si estas con un ubuntu nuevo, recien instalado

sudo apt-get install beryl

Si sos usuario de otra distro o te gusta compilar,hubo algunos pequeños cambios en las dependencias.. Ahora voy a armar un post sobre eso y de como compilar desde el svn.

Saludos y disfruten del dia a dia de Beryl que es muy entretenido y maravilloso.
Va a ser un largo camino hasta la version 0.2, pero lleno de sorpresa y principalmente muyyy divertido :)
Hasta el proximo post.

Etiquetas: , , , ,

4 Comments:

Anonymous fearlex said...

Excelente, ojala este disponible pronto :D

6:28 p.m.  
Blogger Johnny-Five said...

Hola Fearlex :)

No se que distro usas pero si es ubuntu podes instalar la version utlimo snapshot svn desde los repos de Treviño.. ahi ya tenes el nuevo BSM y ahora esta andando bien de nuevo la version svn.. (pasada la tormenta del domingo cuando cambiaron del bsm nuevo al viejo que fue un kaos total de codigo :P

7:19 p.m.  
Anonymous tuxcayc said...

hola, he puesto el svn en ubuntu pero NO HAY BERYL SETTIngS MANAGER!.. no se si sera por el desarrollo del svn o algun bug no se, hice aptitude install beryl...

saludos.

2:30 p.m.  
Blogger Johnny-Five said...

hola tuxcayc

Calculo que instalaste la version svn desde los repositorios de Treviño tal cual dice en este post donde dejaste el comentario.

Dos cosas para hacer. Una que te pases por el foro oficial de beryl en español y te busques este problema ya que es un problema conocido para los que actualizan, le ha pasado a muchos usuarios.

Aca te busque 2 post del problema identico o similar ya solucionado.. fijate:

http://forum.beryl-project.org/viewtopic.php?f=45&t=2158

http://forum.beryl-project.org/viewtopic.php?f=45&t=1858

Otra forma postaeada por arraclan (un usuario del foro) traducida del foro en ingles:
instalar python 2.5, y modificar el archivo /usr/bin/beryl-settings , cambiar:

#!/usr/bin/env python

por

#!/usr/bin/env python2.5

el post original http://forum.beryl-project.org/viewtopic.php?p=12935#p12935




Sino otra forma.. la que haria yo aunque es mas drastica y cruel, pero mas beneficiosa es una instalacion limpia que usando svn es recomendable cada ciertos lapsos cortos de tiempo.

borrar el directorio /home/usurio/.beryl completo

borrar /usr/local/lib/beryl completo
borrar /usr/lib/beryl completo

si aun asi da problemas volver a borrar lo anterior y buscar binarios con nombre *beryl*

Espero que algo de todo esto te sea de ayuda

Saludos y mucha suerte :)

2:52 p.m.  

Publicar un comentario

Links to this post:

Crear un vínculo

<< Home